Language switcher

Sa oled siin

RIA koos partneritega parandas ID-kaardi brauserilaienduses kriitilise vea

RIA uuendas jaanuari lõpus ID-kaardi brauserilaiendust (plugin), et parandada kriitiline viga, mille aitasid avastada Tartu Ülikooli teadlased. ID-tarkvara (ID-Updater) annab kasutajatele märku, kui on vaja tarkvara uuendada. Kui tarkvara veel ei kuva automaatse uuendamise teadet, siis saab uue versioon alla laadida ID.ee kodulehelt.

Detsembris teatas RIA partnerasutus nõrkusest veebilehitseja pluginas ehk programmis, mida kasutatakse ID-kaardiga e-teenusesse digiallkirja andmiseks Chrome’i, FireFoxi, Safari, Internet Exploreri Edge’I ja Edge Chromiumi veebilehitsejas.

Kurjategija saanuks pistikprogrammi nõrkust ära kasutada, kui ta kas võtab üle või omab veebilehte, kus saab ID-kaardiga autentida. Kui kasutaja logib ründaja kontrolli all olevasse portaali ID-kaardiga, siis ründaja saanuks kasutada autentimistoimingu infot, et kasutaja nimel sisse logida mõnda teise e-teenusesse ilma, et ta seda teaks.

„RIAle teadaolevalt ei ole nõrkust ära kasutatud ning ükski kasutaja ei ole tänase info kohaselt kahju kannatanud. Turvaviga on parandatud ning kasutajad ei pea muretsema,“ ütles RIA elektroonilise identiteedi osakonna juht Mark Erlich. „Nõrkus polnud selline, millele võinuks kurjategijad lihtsalt otsa komistada, vaid selle avastamiseks tuli vaeva näha ning teoreetiliseks kuritarvitamiseks oli vaja ka omada kontrolli veebilehe üle, kus saab end ID-kaardiga autentida,“ täpsustas Erlich.

„Paraku on digimaailmas üsna tavaline, et aeg-ajalt avastatakse turvanõrkusi, mis siis kiiresti parandatakse. Ükski lahendus ei püsi turvalisena niisama, vaid neid tuleb kogu aeg uuendada ja kontrollida. RIA, meie partnerid avalikus ja erasektoris ning teadlased tegelevad pidevalt turvanõrkuste väljaselgitamise ja parandamisega, et võimaliku ründaja uute võtetega sammu pidada,“ lisas Erlich.

Tema sõnul ilmestab e-riigi tugevust ja head koostööd kogukonnaga see, et pidevalt kontrollitakse eID lahenduste turvalisust. „Kui nõrkus leitakse, siis antakse sellest kohe teada. Nii saab riik kohe reageerida ning nõrkuse eemaldada. Suur tänu partneritele ja teadlastele, kes avastasid nõrkuse enne kuritarvitamisi ja sellest teada andsid,“ ütles Erlich.

Brauserilaienduse uuendamise järel peavad osad e-teenused omapoolseid muudatusi tegema. See tähendab, et seni kuni pole e-teenus värskeid uuendusi sisse viinud, ei saa sinna ID-kaardiga sisse logida. „Meie teada on selliseid teenuseid vähe. Seega on mõju inimeste netiharjumustele väike,“ lausus Erlich. Suuremad e-teenuse pakkujad on tänaseks vajalikud uuendused teinud ning ID-kaardi kasutamine ei ole neis teenustes seetõttu häiritud.

Seiko Kuik
RIA pressiesindaja
5851 7028
seiko.kuik[@]ria.ee

Veel uudiseid samal teemal

01.10.2021

Kas oled mugavaks ja muretuks e-hääletamiseks valmis?

1.10.2021 – 11.–16. oktoobrini kestva e-hääletamise tarbeks tuleb üle kontrollida ID-kaardi või mobiil-ID sertifikaadid ning kasutada uusimat tarkvara.

15.07.2021

Firefoxi versioon 90 takistab ID-kaardi kasutamist ühiskasutatavas arvutis

15.7.2021 – Firefoxi versioon 90 takistab ID-kaardi kasutamist ühiskasutatavas arvutis