Text size

Spacing

Contrast
Settings

 

Please update your ID-software

The Information System Authority is asking users to update their ID-software. Starting from 22 February, outdated software will no longer support creating and verifying digital signatures.

The reason behind this is the update of the EU Trusted List of Trust Service Providers.

Another reason is the update of the Mozilla Firefox web browser. Changes in the ID-software will help retain the option of creating digital signatures with your ID-card in this web browser.

The new version of the ID-software is available at installer.id.ee.

Starting from Febryary, the software also offers automatic updating.

As of this year, the numbering of the ID-software versions will also change. For simplicity, the versions of the ID-software will be marked by numbers related to the calendar (year + month).

Topic: PKI

Added 08.02.2017

Back to page "News"